$re = '/[()\h]+/';
$str = '+91 (333) 444-5678
+1(333) 456-7890';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;