using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[()\h]+";
string substitution = @"-";
string input = @"+91 (333) 444-5678
+1(333) 456-7890";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}