import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(WSPRD2\\b.*\\r?\\n(?:(?!END\\b).*\\r?\\n)*).*\\bDELESTAT\\b.*\\r?\\n";
final String string = "WSPRD3#/TO/PATH/TASK5\n"
+ " PRIORITY 60\n"
+ "NEEDS 1 MASTER#AAA0RTYU\n"
+ "NEEDS 1 MASTER#DELESTAT\n"
+ "NEEDS 1 MASTER#RAAA1JK\n\n"
+ " FOLLOWS GET_INPUT\n\n"
+ "END\n\n"
+ "WSPRD2#/TO/PATH/TASK6\n"
+ " PRIORITY 60\n"
+ "NEEDS 1 MASTER#AAA0RETU\n"
+ "NEEDS 1 MASTER#DELESTAT\n"
+ "NEEDS 1 MASTER#RAAACCC\n\n"
+ " FOLLOWS GET_INPUT\n\n"
+ "END\n\n"
+ "WSPRD4#/TO/PATH/TASK8\n"
+ " PRIORITY 60\n"
+ "NEEDS 1 MASTER#AAA0RETU\n"
+ "NEEDS 1 MASTER#DELESTAT\n"
+ "NEEDS 1 MASTER#RAAACCC\n\n"
+ " FOLLOWS GET_INPUT\n\n"
+ "END\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}