const regex = /^(WSPRD2\b.*\r?\n(?:(?!END\b).*\r?\n)*).*\bDELESTAT\b.*\r?\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(WSPRD2\\b.*\\r?\\n(?:(?!END\\b).*\\r?\\n)*).*\\bDELESTAT\\b.*\\r?\\n', 'gm')
const str = `WSPRD3#/TO/PATH/TASK5
PRIORITY 60
NEEDS 1 MASTER#AAA0RTYU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAA1JK
FOLLOWS GET_INPUT
END
WSPRD2#/TO/PATH/TASK6
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
FOLLOWS GET_INPUT
END
WSPRD4#/TO/PATH/TASK8
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
FOLLOWS GET_INPUT
END
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);