use strict;
my $str = 'WSPRD3#/TO/PATH/TASK5
PRIORITY 60
NEEDS 1 MASTER#AAA0RTYU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAA1JK
FOLLOWS GET_INPUT
END
WSPRD2#/TO/PATH/TASK6
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
FOLLOWS GET_INPUT
END
WSPRD4#/TO/PATH/TASK8
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
FOLLOWS GET_INPUT
END
';
my $regex = qr/^(WSPRD2\b.*\r?\n(?:(?!END\b).*\r?\n)*).*\bDELESTAT\b.*\r?\n/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";