# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(WSPRD2\b.*\r?\n(?:(?!END\b).*\r?\n)*).*\bDELESTAT\b.*\r?\n"
test_str = ("WSPRD3#/TO/PATH/TASK5\n"
" PRIORITY 60\n"
"NEEDS 1 MASTER#AAA0RTYU\n"
"NEEDS 1 MASTER#DELESTAT\n"
"NEEDS 1 MASTER#RAAA1JK\n\n"
" FOLLOWS GET_INPUT\n\n"
"END\n\n"
"WSPRD2#/TO/PATH/TASK6\n"
" PRIORITY 60\n"
"NEEDS 1 MASTER#AAA0RETU\n"
"NEEDS 1 MASTER#DELESTAT\n"
"NEEDS 1 MASTER#RAAACCC\n\n"
" FOLLOWS GET_INPUT\n\n"
"END\n\n"
"WSPRD4#/TO/PATH/TASK8\n"
" PRIORITY 60\n"
"NEEDS 1 MASTER#AAA0RETU\n"
"NEEDS 1 MASTER#DELESTAT\n"
"NEEDS 1 MASTER#RAAACCC\n\n"
" FOLLOWS GET_INPUT\n\n"
"END\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.