# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\s\.\,]|^)[^#]\w+([\s\.\,]*?|$)/$2/gm;t' <<< "This is a #text, which is #full of #hashtags.
Well, this is not #easy to
#extract #them.
I think I #start to lose: #hope."