import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\s\\.\\,]|^)[^#]\\w+([\\s\\.\\,]*?|$)";
final String string = "This is a #text, which is #full of #hashtags.\n"
+ "Well, this is not #easy to\n"
+ "#extract #them. \n"
+ "I think I #start to lose: #hope.";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}