const regex = /([\s\.\,]|^)[^#]\w+([\s\.\,]*?|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\s\\.\\,]|^)[^#]\\w+([\\s\\.\\,]*?|$)', 'gm')
const str = `This is a #text, which is #full of #hashtags.
Well, this is not #easy to
#extract #them.
I think I #start to lose: #hope.`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);