using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|[\r\n]+)jenkins:([, a-zA-Z_]+)(?:$|[\r\n]+)";
string input = @"jenkins:BASE_TEST, RADIO_TEST
blablablabla";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}