package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|[\r\n]+)jenkins:([, a-zA-Z_]+)(?:$|[\r\n]+)`)
var str = `jenkins:BASE_TEST, RADIO_TEST
blablablabla`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}