re = /(?:^|[\r\n]+)jenkins:([, a-zA-Z_]+)(?:$|[\r\n]+)/
str = 'jenkins:BASE_TEST, RADIO_TEST
blablablabla'
# Print the match result
str.match(re) do |match|
puts match.to_s
end