using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[Sistema Anti-Bot\].*: (.*?)$";
string input = @"[Sistema Anti-Bot] Responda a pergunta a seguir através do comando !r "". Se não responder corretamente será banido. PERGUNTA: Responda essa sequencia: MRSQ""OUWTV2
Exemplo de resposta: !r QWXV@TZLY{3
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}