re = /^\[Sistema Anti-Bot\].*: (.*?)$/m
str = '[Sistema Anti-Bot] Responda a pergunta a seguir através do comando !r ". Se não responder corretamente será banido. PERGUNTA: Responda essa sequencia: MRSQ"OUWTV2
Exemplo de resposta: !r QWXV@TZLY{3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end