import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[Sistema Anti-Bot\\].*: (.*?)$";
final String string = "[Sistema Anti-Bot] Responda a pergunta a seguir através do comando !r \". Se não responder corretamente será banido. PERGUNTA: Responda essa sequencia: MRSQ\"OUWTV2\n"
+ "Exemplo de resposta: !r QWXV@TZLY{3\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}