// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[Sistema Anti-Bot\].*: (.*?)$").unwrap();
let string = "[Sistema Anti-Bot] Responda a pergunta a seguir através do comando !r \". Se não responder corretamente será banido. PERGUNTA: Responda essa sequencia: MRSQ\"OUWTV2
Exemplo de resposta: !r QWXV@TZLY{3
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}