$re = '/^\[Sistema Anti-Bot\].*: (.*?)$/m';
$str = '[Sistema Anti-Bot] Responda a pergunta a seguir através do comando !r ". Se não responder corretamente será banido. PERGUNTA: Responda essa sequencia: MRSQ"OUWTV2
Exemplo de resposta: !r QWXV@TZLY{3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);