# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+\.\d+\.\d+\.\d+)/***.***.*.*/gm;t' <<< "192.168.0.2"