package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+\.\d+\.\d+\.\d+)`)
var str = `192.168.0.2`
var substitution = "***.***.*.*"
fmt.Println(re.ReplaceAllString(str, substitution))
}