re = /(\d+\.\d+\.\d+\.\d+)/m
str = '192.168.0.2'
subst = '***.***.*.*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result