// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+\.\d+\.\d+\.\d+)").unwrap();
let string = "192.168.0.2";
let substitution = "***.***.*.*";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}