$re = '/(\d+\.\d+\.\d+\.\d+)/m';
$str = '192.168.0.2';
$subst = "***.***.*.*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;