using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((<img)([A-Za-z0-9""'=_\-.\/\s]+)(\/>))";
string input = @"<p class=""pic""><img src=""image/pic003.jpg"" alt="" class=""w21em"" /></p>
<p class=""footnote"">oremIpsum loremIpsum oremIpsum loremIpsum<img src=""image/pic027.jpg"" alt="" class=""w0em2"" />oremIpsum loremIpsum<img src=""image/pic028.jpg"" alt="" class=""w0em2"" />`";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}