import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((<img)([A-Za-z0-9\"'=_\\-.\\/\\s]+)(\\/>))";
final String string = "<p class=\"pic\"><img src=\"image/pic003.jpg\" alt=\"\" class=\"w21em\" /></p>\n\n"
+ "<p class=\"footnote\">oremIpsum loremIpsum oremIpsum loremIpsum<img src=\"image/pic027.jpg\" alt=\"\" class=\"w0em2\" />oremIpsum loremIpsum<img src=\"image/pic028.jpg\" alt=\"\" class=\"w0em2\" />`";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}