$re = '/((<img)([A-Za-z0-9"\'=_\-.\/\s]+)(\/>))/m';
$str = '<p class="pic"><img src="image/pic003.jpg" alt="" class="w21em" /></p>
<p class="footnote">oremIpsum loremIpsum oremIpsum loremIpsum<img src="image/pic027.jpg" alt="" class="w0em2" />oremIpsum loremIpsum<img src="image/pic028.jpg" alt="" class="w0em2" />`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);