// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)((<img)([A-Za-z0-9"'=_\-.\/\s]+)(\/>))"#).unwrap();
let string = "<p class=\"pic\"><img src=\"image/pic003.jpg\" alt=\"\" class=\"w21em\" /></p>
<p class=\"footnote\">oremIpsum loremIpsum oremIpsum loremIpsum<img src=\"image/pic027.jpg\" alt=\"\" class=\"w0em2\" />oremIpsum loremIpsum<img src=\"image/pic028.jpg\" alt=\"\" class=\"w0em2\" />`";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}