package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((<img)([A-Za-z0-9"'=_\-.\/\s]+)(\/>))`)
var str = `<p class="pic"><img src="image/pic003.jpg" alt="" class="w21em" /></p>
<p class="footnote">oremIpsum loremIpsum oremIpsum loremIpsum<img src="image/pic027.jpg" alt="" class="w0em2" />oremIpsum loremIpsum<img src="image/pic028.jpg" alt="" class="w0em2" />\``
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}