import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " ";
final String string = "The European(@)l a n g u a g es(@)ar e(@)members(@)of(@)the(@)same(@)fa m i l y \n"
+ ". Their(@)sep a rate(@)e xi ste nce(@)is a myth .(@)F or(@)s c i e n c e , music, \n"
+ "sport , etc, Europe uses the(@)s a m e(@)v oca bula ry. The languages(@)o n l y(@)d \n"
+ "i f f e r(@)i n(@)t heir(@)grammar, their(@)pro nu n c iation(@)and their most common \n"
+ "words. Everyone realizes why a new common language would be desirable: one could \n"
+ "refuse to pay expensive translators.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}