package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\B(?:ion|s)\b`)
var str = `houses reflection`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}