use strict;
my $str = 'houses reflection';
my $regex = qr/\B(?:ion|s)\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";