$re = '/\B(?:ion|s)\b/m';
$str = 'houses reflection';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;