const regex = new RegExp('\\B(?:ion|s)\\b', 'gm')
const str = `houses reflection`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);