import re
regex = re.compile(r"\B(?:ion|s)\b", flags=re.MULTILINE)
test_str = "houses reflection"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)