using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<timestamp>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}\.\d{1,3})\s+(?<level>\w+)\s+---\s+\[(?<threadinfo>(?<threadtype>\w+)\s+:\s+(?<thread>\d+))\]\s+(?<logger>[a-zA-Z][a-zA-Z0-9_]*(\.[a-zA-Z0-9_]+)*[0-9a-zA-Z_]*)\s+:\s+(?<body>.*)";
string input = @"2020-11-02 08:35:24.407 DEBUG --- [Default : 3] com.nm.ross.client.commons.XMLTable : Reading /nmlstage/ross/data/MVRValidationTable.properties";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}