# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<timestamp>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}\.\d{1,3})\s+(?<level>\w+)\s+---\s+\[(?<threadinfo>(?<threadtype>\w+)\s+:\s+(?<thread>\d+))\]\s+(?<logger>[a-zA-Z][a-zA-Z0-9_]*(\.[a-zA-Z0-9_]+)*[0-9a-zA-Z_]*)\s+:\s+(?<body>.*)"
test_str = "2020-11-02 08:35:24.407 DEBUG --- [Default : 3] com.nm.ross.client.commons.XMLTable : Reading /nmlstage/ross/data/MVRValidationTable.properties"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.