const regex = /^(?<timestamp>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}\.\d{1,3})\s+(?<level>\w+)\s+---\s+\[(?<threadinfo>(?<threadtype>\w+)\s+:\s+(?<thread>\d+))\]\s+(?<logger>[a-zA-Z][a-zA-Z0-9_]*(\.[a-zA-Z0-9_]+)*[0-9a-zA-Z_]*)\s+:\s+(?<body>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<timestamp>\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2}\\.\\d{1,3})\\s+(?<level>\\w+)\\s+---\\s+\\[(?<threadinfo>(?<threadtype>\\w+)\\s+:\\s+(?<thread>\\d+))\\]\\s+(?<logger>[a-zA-Z][a-zA-Z0-9_]*(\\.[a-zA-Z0-9_]+)*[0-9a-zA-Z_]*)\\s+:\\s+(?<body>.*)', 'gm')
const str = `2020-11-02 08:35:24.407 DEBUG --- [Default : 3] com.nm.ross.client.commons.XMLTable : Reading /nmlstage/ross/data/MVRValidationTable.properties`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}