package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<timestamp>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}\.\d{1,3})\s+(?<level>\w+)\s+---\s+\[(?<threadinfo>(?<threadtype>\w+)\s+:\s+(?<thread>\d+))\]\s+(?<logger>[a-zA-Z][a-zA-Z0-9_]*(\.[a-zA-Z0-9_]+)*[0-9a-zA-Z_]*)\s+:\s+(?<body>.*)`)
var str = `2020-11-02 08:35:24.407 DEBUG --- [Default : 3] com.nm.ross.client.commons.XMLTable : Reading /nmlstage/ross/data/MVRValidationTable.properties`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}