import Foundation
let pattern = #"^(?<timestamp>\d{4}-\d{2}-\d{2} \d{2}:\d{2}:\d{2}\.\d{1,3})\s+(?<level>\w+)\s+---\s+\[(?<threadinfo>(?<threadtype>\w+)\s+:\s+(?<thread>\d+))\]\s+(?<logger>[a-zA-Z][a-zA-Z0-9_]*(\.[a-zA-Z0-9_]+)*[0-9a-zA-Z_]*)\s+:\s+(?<body>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2020-11-02 08:35:24.407 DEBUG --- [Default : 3] com.nm.ross.client.commons.XMLTable : Reading /nmlstage/ross/data/MVRValidationTable.properties"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)