#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\[(?=[^][]*])(\w+)|\G(?!^))\h+(\w+)="([^"]+)""
Local $sString = "[specs product="test" category="body"]" & @CRLF & _
"[pricelist keyword="216"]" & @CRLF & _
"[specs product="test2" category="network"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")