re = /(?:\[(?=[^][]*])(\w+)|\G(?!^))\h+(\w+)="([^"]+)"/
str = '[specs product="test" category="body"]
[pricelist keyword="216"]
[specs product="test2" category="network"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end