using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[(?=[^][]*])(\w+)|\G(?!^))\h+(\w+)=""([^""]+)""";
string input = @"[specs product=""test"" category=""body""]
[pricelist keyword=""216""]
[specs product=""test2"" category=""network""]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}