import re
regex = re.compile(r"(?:\[(?=[^][]*])(\w+)|\G(?!^))\h+(\w+)=\"([^\"]+)\"")
test_str = ("[specs product=\"test\" category=\"body\"]\n"
"[pricelist keyword=\"216\"]\n"
"[specs product=\"test2\" category=\"network\"]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")