import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([[:alpha:]]+)(.?)([[:alpha:]]*)(\\.([[:alpha:][:digit:]]*))?@[[:alpha:]]*\\.[[:alpha:]]{3,7}\\b";
final String string = "//Valid\n"
+ "customer@yahoo.com \n"
+ "customer.name@yahoo.com \n"
+ "customer_name@yahoo.com \n"
+ "customer.name.name2@yahoo.com \n\n"
+ "//Invalid\n"
+ "customer@yahoo..com\n"
+ "#customer@yahoo.com \n"
+ "cu$$tomer@yahoo.com \n"
+ "customer@yahoo.c \n"
+ "customer@yahoo.commmmmmm \n"
+ "customer.name.#name2@yahoo.com ";
final String subst = "$1#$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}