const regex = /^([[:alpha:]]+)(.?)([[:alpha:]]*)(\.([[:alpha:][:digit:]]*))?@[[:alpha:]]*\.[[:alpha:]]{3,7}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([[:alpha:]]+)(.?)([[:alpha:]]*)(\\.([[:alpha:][:digit:]]*))?@[[:alpha:]]*\\.[[:alpha:]]{3,7}\\b', 'gm')
const str = `//Valid
customer@yahoo.com
customer.name@yahoo.com
customer_name@yahoo.com
customer.name.name2@yahoo.com
//Invalid
customer@yahoo..com
#customer@yahoo.com
cu\$\$tomer@yahoo.com
customer@yahoo.c
customer@yahoo.commmmmmm
customer.name.#name2@yahoo.com `;
const subst = `$1#$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);