import re
regex = re.compile(r"^([[:alpha:]]+)(.?)([[:alpha:]]*)(\.([[:alpha:][:digit:]]*))?@[[:alpha:]]*\.[[:alpha:]]{3,7}\b", flags=re.MULTILINE)
test_str = ("//Valid\n"
"customer@yahoo.com \n"
"customer.name@yahoo.com \n"
"customer_name@yahoo.com \n"
"customer.name.name2@yahoo.com \n\n"
"//Invalid\n"
"customer@yahoo..com\n"
"#customer@yahoo.com \n"
"cu$$tomer@yahoo.com \n"
"customer@yahoo.c \n"
"customer@yahoo.commmmmmm \n"
"customer.name.#name2@yahoo.com ")
subst = "$1#$2"
result = regex.sub(subst, test_str)
if result:
print(result)