// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([[:alpha:]]+)(.?)([[:alpha:]]*)(\.([[:alpha:][:digit:]]*))?@[[:alpha:]]*\.[[:alpha:]]{3,7}\b").unwrap();
let string = "//Valid
customer@yahoo.com
customer.name@yahoo.com
customer_name@yahoo.com
customer.name.name2@yahoo.com
//Invalid
customer@yahoo..com
#customer@yahoo.com
cu$$tomer@yahoo.com
customer@yahoo.c
customer@yahoo.commmmmmm
customer.name.#name2@yahoo.com ";
let substitution = "$1#$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}