$re = '/^([[:alpha:]]+)(.?)([[:alpha:]]*)(\.([[:alpha:][:digit:]]*))?@[[:alpha:]]*\.[[:alpha:]]{3,7}\b/m';
$str = '//Valid
customer@yahoo.com
customer.name@yahoo.com
customer_name@yahoo.com
customer.name.name2@yahoo.com
//Invalid
customer@yahoo..com
#customer@yahoo.com
cu$$tomer@yahoo.com
customer@yahoo.c
customer@yahoo.commmmmmm
customer.name.#name2@yahoo.com ';
$subst = "$1#$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;