using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"class\s*([a-zA-Z][a-zA-Z\d_\$]*)";
string input = @"class test {
/* class bidule */
class smurf {
}
}
class test3{
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}