import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class\\s*([a-zA-Z][a-zA-Z\\d_\\$]*)";
final String string = "class test {\n"
+ " /* class bidule */ \n"
+ " class smurf {\n"
+ " }\n"
+ "}\n\n"
+ "class test3{\n"
+ "}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}