package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)class\s*([a-zA-Z][a-zA-Z\d_\$]*)`)
var str = `class test {
/* class bidule */
class smurf {
}
}
class test3{
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}